summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 20:49:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-28 04:00:14 +0000
commitb2b55cac12516c971e819d1d9087361de51d41c7 (patch)
tree1aa139862d4f4f0917607882dce79b01265261d6 /dev-python/thriftpy/thriftpy-0.3.9.ebuild
parentsci-mathematics/pymc3: version bump (diff)
downloadgentoo-b2b55cac12516c971e819d1d9087361de51d41c7.tar.gz
gentoo-b2b55cac12516c971e819d1d9087361de51d41c7.tar.bz2
gentoo-b2b55cac12516c971e819d1d9087361de51d41c7.zip
dev-python/thriftpy: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/thriftpy/thriftpy-0.3.9.ebuild')
-rw-r--r--dev-python/thriftpy/thriftpy-0.3.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/thriftpy/thriftpy-0.3.9.ebuild b/dev-python/thriftpy/thriftpy-0.3.9.ebuild
new file mode 100644
index 000000000000..d0d687f397ce
--- /dev/null
+++ b/dev-python/thriftpy/thriftpy-0.3.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of Apache Thrift"
+HOMEPAGE="https://thriftpy.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/toro[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.23[${PYTHON_USEDEP}]
+"