summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:57:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:59 +0100
commitc78290dcb3b0694f05f0f90915b7e31febce648d (patch)
tree7dcd216a0710a9ad57ebabc2159f1e538edc21a8 /dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
parentdev-python/pythong: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-c78290dcb3b0694f05f0f90915b7e31febce648d.tar.gz
gentoo-c78290dcb3b0694f05f0f90915b7e31febce648d.tar.bz2
gentoo-c78290dcb3b0694f05f0f90915b7e31febce648d.zip
dev-python/thunarx-python: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild')
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..0a243f4cf713
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/glib-2.30:2
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=xfce-base/thunar-1.7.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}