summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 15:54:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 17:59:43 +0100
commit513ea52ec47d187d4934e816a1f2a6a2b1d85d0b (patch)
treedef6d068be02c14017956af95b7d7288d68a88b7 /dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
parentmedia-sound/vmpk: Drop 0.7.2-r1 (diff)
downloadgentoo-513ea52ec47d187d4934e816a1f2a6a2b1d85d0b.tar.gz
gentoo-513ea52ec47d187d4934e816a1f2a6a2b1d85d0b.tar.bz2
gentoo-513ea52ec47d187d4934e816a1f2a6a2b1d85d0b.zip
dev-python/thunarx-python: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python/thunarx-python-0.5.2.ebuild')
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
new file mode 100644
index 000000000000..3c38ae815633
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/thunar-1.7.0
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}