summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-12 10:10:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-12 10:26:40 +0100
commit2fbf13a68615f07fcb723153977f08b5337bc0ce (patch)
tree1b697340ead7f4bde099377221c1b7e913ab050c /dev-python/tifffile
parentdev-python/ukkonen: fix build on musl (diff)
downloadgentoo-2fbf13a68615f07fcb723153977f08b5337bc0ce.tar.gz
gentoo-2fbf13a68615f07fcb723153977f08b5337bc0ce.tar.bz2
gentoo-2fbf13a68615f07fcb723153977f08b5337bc0ce.zip
dev-python/tifffile: New package, v2021.11.2, test dep of imageio
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/metadata.xml11
-rw-r--r--dev-python/tifffile/tifffile-2021.11.2.ebuild54
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
new file mode 100644
index 000000000000..e8c930b64fcd
--- /dev/null
+++ b/dev-python/tifffile/Manifest
@@ -0,0 +1 @@
+DIST tifffile-2021.11.2.gh.tar.gz 261953 BLAKE2B 039e25b173d2074b5a869394bb40cd62410b34c8a86bf047cd203aad6ab0e3217d0f4006bb092840acb314598c73619e48c66daa04c81f9965ca46b81f055d6e SHA512 5bd3340af027547bf07d78523c5c2abcecb428606d72daa446c7f3cd06f7c8da015e20cd0f4ebeb1e9a49ce0aaf6c2840170dad7a8a28e403716d4bdb1ba2238
diff --git a/dev-python/tifffile/metadata.xml b/dev-python/tifffile/metadata.xml
new file mode 100644
index 000000000000..f3fa5ef3f318
--- /dev/null
+++ b/dev-python/tifffile/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">tifffile</remote-id>
+ <remote-id type="github">cgohlke/tifffile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tifffile/tifffile-2021.11.2.ebuild b/dev-python/tifffile/tifffile-2021.11.2.ebuild
new file mode 100644
index 000000000000..52adc8a6887f
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2021.11.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/dask[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # requires files not in tarball (upstream misses this one in skip)
+ tests/test_tifffile.py::test_write_predictor
+)