summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-29 11:30:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:12:00 +0300
commit9e6aa49462f5ab2c033202b5f8f47ff6dca67294 (patch)
treed32849bddacb5f408c94f72d2fdd0a419b800f3d /dev-python/tifffile
parentdev-python/iminuit: add 2.15.1 (diff)
downloadgentoo-9e6aa49462f5ab2c033202b5f8f47ff6dca67294.tar.gz
gentoo-9e6aa49462f5ab2c033202b5f8f47ff6dca67294.tar.bz2
gentoo-9e6aa49462f5ab2c033202b5f8f47ff6dca67294.zip
dev-python/tifffile: add 2022.7.28
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.7.28.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 0516edac84ea..88f31bde4230 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2022.5.4.gh.tar.gz 290116 BLAKE2B 4c608ad38ad7ada0e1b41512eae7b4109680cab1f5623ea3cd6c01dfe17b534b518868ee21879ecfa9909f7680a04fbb63967b5c8064062cc325286baaaccb6b SHA512 cc6139872c42e0e2840a9774989b5cba57ef8957e2efa4349e7b224c61ebb8ad34287b9305dddd85b1239d03be4ada73526259b038c19c73513007e5f63d224d
+DIST tifffile-2022.7.28.gh.tar.gz 309010 BLAKE2B 4a52a688ce7f09265592f8bd2bed2eaf9648304908aa1b190c07a22b58f10bb3f71f9ea1f9a612a2592f75f457acc04cc2139ef0cbd75ea40a7e91408075062b SHA512 12647884cb77fc8e414c09aface82def1ad2bb0a11a1f17fa00e6954cf565a906b6a8c9e861d0a476a86ef8ea25da12d1069199109cb84030d312021d722f23e
diff --git a/dev-python/tifffile/tifffile-2022.7.28.ebuild b/dev-python/tifffile/tifffile-2022.7.28.ebuild
new file mode 100644
index 000000000000..c7b39355f0d6
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.7.28.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)