summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-26 10:54:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-26 11:37:36 +0100
commitd212898413f7c936e243d0ed64d812711fe5a624 (patch)
tree50360df7657da4e50387f4151bc49ece7fe27b2f /dev-python/tifffile
parentdev-python/importlib_resources: Bump to 5.6.0 (diff)
downloadgentoo-d212898413f7c936e243d0ed64d812711fe5a624.tar.gz
gentoo-d212898413f7c936e243d0ed64d812711fe5a624.tar.bz2
gentoo-d212898413f7c936e243d0ed64d812711fe5a624.zip
dev-python/tifffile: Bump to 2022.3.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.3.25.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 0267cf48b0ee..a6d075151da1 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2022.3.16.gh.tar.gz 263653 BLAKE2B fcd30e2fd38a12438332badb17e937ab095a8088f9c878b84166a67c7486f436a76d39832df22362f7a74de5da537602da82c982fb4dc0699fba1603adefdcef SHA512 8069a87b241cbb11b3efa8ff679106f2f11ff9045d790fb1612076a60b87791f30afffb55b57d19b70ab4441935f418ad91fb0956ab572890704023e63dea84a
+DIST tifffile-2022.3.25.gh.tar.gz 265082 BLAKE2B dd5f3705cb7203fe943b97a5ed5c000b44abf48ec748f38a1468e27e82bd980e4100dd14af5cfd6af5bdee9d0036c5dce37efca1e515f2eb283c0e221150915a SHA512 dc9018991989ca4b89be6f315aaa45ff2fb94c504dd4c1790af1ec68e05a1da85560f5098df2f460b726cea0d4b0e4fc3f12d493dc1a1db8e2cc35d86f547ddf
diff --git a/dev-python/tifffile/tifffile-2022.3.25.ebuild b/dev-python/tifffile/tifffile-2022.3.25.ebuild
new file mode 100644
index 000000000000..bcfdee9f5d5f
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.3.25.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)