summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tinycss
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tinycss')
-rw-r--r--dev-python/tinycss/Manifest1
-rw-r--r--dev-python/tinycss/metadata.xml9
-rw-r--r--dev-python/tinycss/tinycss-0.3.ebuild31
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tinycss/Manifest b/dev-python/tinycss/Manifest
new file mode 100644
index 000000000000..28f31721e822
--- /dev/null
+++ b/dev-python/tinycss/Manifest
@@ -0,0 +1 @@
+DIST tinycss-0.3.tar.gz 72860 SHA256 a4adabd1c417080372c789220f7f9985995e74f2fb612848306872a232862cde SHA512 1fdf29777ee7b3ef39cf2169d8f464a7e5aea850de8a7976acf3ed9e73e831ea0d7ee52b4c8c9979b2263509cbffe1bde85cf6da178ddeaac9009ace7a2b4441 WHIRLPOOL 2fc7433e2410e8641f2c939f2d22ba3ab423908e20213559b34e8fb5002776a9ddfe7640c8a68c59af05b1c0e1493481c315011bef8055afd858e7a4c66ebdd4
diff --git a/dev-python/tinycss/metadata.xml b/dev-python/tinycss/metadata.xml
new file mode 100644
index 000000000000..dbd435291a84
--- /dev/null
+++ b/dev-python/tinycss/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">tinycss</remote-id>
+ <remote-id type="github">SimonSapin/tinycss</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tinycss/tinycss-0.3.ebuild b/dev-python/tinycss/tinycss-0.3.ebuild
new file mode 100644
index 000000000000..a0a41deb439e
--- /dev/null
+++ b/dev-python/tinycss/tinycss-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="http://github.com/SimonSapin/tinycss/ http://packages.python.org/tinycss/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES README.rst )
+
+python_test() {
+ export TINYCSS_SKIP_SPEEDUPS_TESTS=1
+ local test
+ for test in ${PN}/tests/test_*.py; do
+ py.test $test
+ done
+}