summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-12-31 22:14:13 -0500
committerMike Gilbert <floppym@gentoo.org>2016-12-31 22:14:13 -0500
commit5576cb68bed713b2a71650206e5f639dd0ff7ffd (patch)
treeb8e4f732f5d3ff7a33f9037e21f2d2eba484159c /dev-python/tlslite/tlslite-0.4.9-r2.ebuild
parentdev-python/tlslite: drop m2crypto and pycrypto deps (diff)
downloadgentoo-5576cb68bed713b2a71650206e5f639dd0ff7ffd.tar.gz
gentoo-5576cb68bed713b2a71650206e5f639dd0ff7ffd.tar.bz2
gentoo-5576cb68bed713b2a71650206e5f639dd0ff7ffd.zip
dev-python/tlslite: revbump for RDEPEND change
Package-Manager: Portage-2.3.3_p12, Repoman-2.3.1_p5
Diffstat (limited to 'dev-python/tlslite/tlslite-0.4.9-r2.ebuild')
-rw-r--r--dev-python/tlslite/tlslite-0.4.9-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tlslite/tlslite-0.4.9-r2.ebuild b/dev-python/tlslite/tlslite-0.4.9-r2.ebuild
new file mode 100644
index 000000000000..d877ba1f7b7a
--- /dev/null
+++ b/dev-python/tlslite/tlslite-0.4.9-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="TLS Lite is a free python library that implements SSL 3.0 and TLS 1.0/1.1"
+HOMEPAGE="http://trevp.net/tlslite/ https://pypi.python.org/pypi/tlslite https://github.com/trevp/tlslite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#Refrain for now setting IUSE test and deps of test given test restricted.
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+# Tests still hang
+python_test() {
+ cd tests || die
+ "${PYTHON}" "${S}"/tests/tlstest.py client localhost:4443 . || die
+ "${PYTHON}" "${S}"/tests/tlstest.py server localhost:4442 . || die
+}
+
+python_install_all(){
+ use doc && HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "GMP support" dev-python/gmpy
+}