summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-05-20 14:57:05 -0700
committerMatt Turner <mattst88@gentoo.org>2020-05-20 15:04:08 -0700
commitba254b6bdc8ce4b8dc928d552959492ae06ad7a2 (patch)
treeb088d045c04232c64503193c28ca8e47d7a452bf /dev-python/toml/toml-0.10.1.ebuild
parentdev-lang/erlang: bump up to 23.0.1 (diff)
downloadgentoo-ba254b6bdc8ce4b8dc928d552959492ae06ad7a2.tar.gz
gentoo-ba254b6bdc8ce4b8dc928d552959492ae06ad7a2.tar.bz2
gentoo-ba254b6bdc8ce4b8dc928d552959492ae06ad7a2.zip
dev-python/toml: Version bump to 0.10.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/toml/toml-0.10.1.ebuild')
-rw-r--r--dev-python/toml/toml-0.10.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/toml/toml-0.10.1.ebuild b/dev-python/toml/toml-0.10.1.ebuild
new file mode 100644
index 000000000000..2dc1660a0cae
--- /dev/null
+++ b/dev-python/toml/toml-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*') )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}