summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 18:39:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 18:48:55 +0200
commit2e15acf5334bc0f0f2840d3b8f41144a1667d125 (patch)
tree5360b1622f92e178c49cb30a0055c4fffa2d905a /dev-python/toml
parentdev-libs/libsigsegv: Keyword 2.14 mips, #840239 (diff)
downloadgentoo-2e15acf5334bc0f0f2840d3b8f41144a1667d125.tar.gz
gentoo-2e15acf5334bc0f0f2840d3b8f41144a1667d125.tar.bz2
gentoo-2e15acf5334bc0f0f2840d3b8f41144a1667d125.zip
dev-python/toml: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toml')
-rw-r--r--dev-python/toml/toml-0.10.2-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/toml/toml-0.10.2-r1.ebuild b/dev-python/toml/toml-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..7389b2fc2a62
--- /dev/null
+++ b/dev-python/toml/toml-0.10.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="
+ https://github.com/uiri/toml/
+ https://pypi.org/project/toml/
+"
+SRC_URI="
+ https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? (
+ https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz
+ -> toml-test-${TOML_TEST_VER}.tar.gz
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}