summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-11 09:08:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-11 09:56:53 +0200
commita45b5416a5c819c7943bfee7726a0cd311eb6769 (patch)
tree09ab32a2369e5fe1f181027d84fa5ab65f4be072 /dev-python/tomli-w
parentdev-python/flit_core: Bump to 3.4.0 (diff)
downloadgentoo-a45b5416a5c819c7943bfee7726a0cd311eb6769.tar.gz
gentoo-a45b5416a5c819c7943bfee7726a0cd311eb6769.tar.bz2
gentoo-a45b5416a5c819c7943bfee7726a0cd311eb6769.zip
dev-python/tomli-w: New package, dep of dev-python/flit
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest1
-rw-r--r--dev-python/tomli-w/metadata.xml12
-rw-r--r--dev-python/tomli-w/tomli-w-0.3.0.ebuild26
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
new file mode 100644
index 000000000000..d51775295d71
--- /dev/null
+++ b/dev-python/tomli-w/Manifest
@@ -0,0 +1 @@
+DIST tomli-w-0.3.0.gh.tar.gz 61366 BLAKE2B 1ca3d50237d41fb22e8d506d2d8af3c5d9f690161a44439d3a79038bda7a67a6af9ad62b077169b5c2bdaee2110a3be5e3eec652aa8866a20c5841662f18a7e1 SHA512 618b93f2d98eee4fafe502e25f8770dc58558b25d9ec548fa5d0a6bdd8914e487fb1d16b68d138e0f8a48a6e5713c23e4d1a6daf70c8eafa27630fee05dfe8df
diff --git a/dev-python/tomli-w/metadata.xml b/dev-python/tomli-w/metadata.xml
new file mode 100644
index 000000000000..499f307591cc
--- /dev/null
+++ b/dev-python/tomli-w/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">hukkin/tomli-w</remote-id>
+ <remote-id type="pypi">tomli_w</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tomli-w/tomli-w-0.3.0.ebuild b/dev-python/tomli-w/tomli-w-0.3.0.ebuild
new file mode 100644
index 000000000000..48aa3a6e56e9
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli_w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest