summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 11:44:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-08 09:53:51 +0200
commit849414260a6023f66a0984203f165f58d367be54 (patch)
treeef1b635ea8c300aed99186754b0ee640ebfd4bab /dev-python/tomli/tomli-2.0.1-r1.ebuild
parentdistutils-r1.eclass: Introduce DISTUTILS_USE_PEP517=no mode (diff)
downloadgentoo-849414260a6023f66a0984203f165f58d367be54.tar.gz
gentoo-849414260a6023f66a0984203f165f58d367be54.tar.bz2
gentoo-849414260a6023f66a0984203f165f58d367be54.zip
dev-python/tomli: Use DISTUTILS_USE_PEP517=no
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli/tomli-2.0.1-r1.ebuild')
-rw-r--r--dev-python/tomli/tomli-2.0.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tomli/tomli-2.0.1-r1.ebuild b/dev-python/tomli/tomli-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..338d877a350d
--- /dev/null
+++ b/dev-python/tomli/tomli-2.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/
+"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+ -> ${P}-py3-none-any.whl.zip
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ python_domodule src/tomli "${WORKDIR}"/*.dist-info
+}