summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-08 20:40:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-08 21:14:31 +0100
commit7ae6914d8c4a7e66d03573d61d79d9f31a91245c (patch)
tree1c7711fe67f1bb119b8f021b4ddafb17ab60e8bc /dev-python/tomli/tomli-2.0.1.ebuild
parentdev-python/tomlkit: Bump to 0.9.2 (diff)
downloadgentoo-7ae6914d8c4a7e66d03573d61d79d9f31a91245c.tar.gz
gentoo-7ae6914d8c4a7e66d03573d61d79d9f31a91245c.tar.bz2
gentoo-7ae6914d8c4a7e66d03573d61d79d9f31a91245c.zip
dev-python/tomli: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli/tomli-2.0.1.ebuild')
-rw-r--r--dev-python/tomli/tomli-2.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tomli/tomli-2.0.1.ebuild b/dev-python/tomli/tomli-2.0.1.ebuild
new file mode 100644
index 000000000000..fa824ad81635
--- /dev/null
+++ b/dev-python/tomli/tomli-2.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+ -> ${P}-py3-none-any.whl.zip"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ app-arch/unzip"
+
+distutils_enable_tests unittest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_test() {
+ eunittest -s "${P}"
+}
+
+python_install() {
+ python_domodule tomli *.dist-info
+}