summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:35:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:24 +0100
commit458e6110c2cf91a55bd69661d891ef6e5efe1f71 (patch)
tree39cf835c4a56f2c24b777a1be15f6d12a452effc /dev-python/tomli
parentdev-python/tomli: Bump to 1.2.3 (diff)
downloadgentoo-458e6110c2cf91a55bd69661d891ef6e5efe1f71.tar.gz
gentoo-458e6110c2cf91a55bd69661d891ef6e5efe1f71.tar.bz2
gentoo-458e6110c2cf91a55bd69661d891ef6e5efe1f71.zip
dev-python/tomli: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/Manifest2
-rw-r--r--dev-python/tomli/tomli-2.0.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomli/Manifest b/dev-python/tomli/Manifest
index 8b957c50b942..a87b2b64dca0 100644
--- a/dev-python/tomli/Manifest
+++ b/dev-python/tomli/Manifest
@@ -2,3 +2,5 @@ DIST tomli-1.2.2-py3-none-any.whl.zip 12118 BLAKE2B ae1dbc14e3c7c79240a327f3fb62
DIST tomli-1.2.2.gh.tar.gz 123150 BLAKE2B b07527a2a83615030037867c6011440a3814cbe265e8a760cca08e324954dbf7d1a393bc900559ddfc1bcbe1911f758948051823d9ef830ee05abb2539374dff SHA512 460ad8ae9a342d82ef12911c0d0e246c1434a5d40d898e91f6c05bf37b7bf9921da05e004c36907d623a797a7a215c1c3faf3f9a2b940f3867b142847a188605
DIST tomli-1.2.3-py3-none-any.whl.zip 12122 BLAKE2B ad0037b3761a13043bffb5875a25c7e18b71ac8cdb4491ca9c7cc60f593acd588ac38d7d9f7c48da217adfcfe5100bed3af215da2bffc06064d4817bf9923ec3 SHA512 7dd3ca4851728ef78cb288f51a446ddf25be5a6454a8dbfb4987f7078fe744ac76021ed7046bdbb630b4989479bc932ce649c5e3af33f43724f9714fb755209f
DIST tomli-1.2.3.gh.tar.gz 123142 BLAKE2B e8af1618aa962d7ff56d319c3a789c7655d9cb95e79f27b90cd9f9c7e978d2e29a49abef3884c4f53788305e54f8e919992d65fcec12679a9346690d86b7dd6a SHA512 270dbfe1df2e7f2692c35be5cc45e0b78e9e045e150fe959f4d6db8e3022126e7c17338636e57ba553fd928cbfd227938cfcd13128e1f05ee8cff29327594c61
+DIST tomli-2.0.0-py3-none-any.whl.zip 12127 BLAKE2B 1a680c2baa158db3892fc616e4fa74aa197862dcdb792db51e16e00fd949c6e7554235ac083ea1524d5ae952c911899c512f37d1500786dae401df4086c5ca15 SHA512 6191981e9771dedc5dc225734295774c75a272d03edfbea7415d2b4c09531d5022dba53affc47baf817ff9cc5945d8d62ea3eb67bd69e146a07eaa35dec5acc0
+DIST tomli-2.0.0.gh.tar.gz 123262 BLAKE2B cddd21e3297ee71608f2f3e08023ec8d86f8295133ee78a16bf3c4dca080d94ade1f7d8c43d262d5a5f0287ea743068f57d47336d5d9ec684cdfaf485194a2e6 SHA512 dc7cdfadaca74f39dd6cb00686ec2e5b47b8ee3dbec9bd0a289a6ff78619cfdbf125adb6253d838f197722f4389690872a3ca870664b7785c19f3c2bb1a18231
diff --git a/dev-python/tomli/tomli-2.0.0.ebuild b/dev-python/tomli/tomli-2.0.0.ebuild
new file mode 100644
index 000000000000..c62c576ca961
--- /dev/null
+++ b/dev-python/tomli/tomli-2.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+ -> ${P}-py3-none-any.whl.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ app-arch/unzip
+ test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_install() {
+ python_domodule tomli "${WORKDIR}"/*.dist-info
+}