summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 16:44:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 22:33:43 +0200
commit63ef3df85dab9c5900e4ccf3420f5fb7ae34220c (patch)
tree6e06930fef008c4a1845886e2e3881b653cbef93 /dev-python/tomli
parentdev-lang/python: Remove old (diff)
downloadgentoo-63ef3df85dab9c5900e4ccf3420f5fb7ae34220c.tar.gz
gentoo-63ef3df85dab9c5900e4ccf3420f5fb7ae34220c.tar.bz2
gentoo-63ef3df85dab9c5900e4ccf3420f5fb7ae34220c.zip
dev-python/tomli: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/tomli-2.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/tomli/tomli-2.0.1.ebuild b/dev-python/tomli/tomli-2.0.1.ebuild
index a3ce67d66ee5..ca6baab56cc2 100644
--- a/dev-python/tomli/tomli-2.0.1.ebuild
+++ b/dev-python/tomli/tomli-2.0.1.ebuild
@@ -5,19 +5,21 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A lil' TOML parser"
HOMEPAGE="
https://pypi.org/project/tomli/
- https://github.com/hukkin/tomli/"
+ https://github.com/hukkin/tomli/
+"
SRC_URI="
https://github.com/hukkin/tomli/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
- -> ${P}-py3-none-any.whl.zip"
+ -> ${P}-py3-none-any.whl.zip
+"
S=${WORKDIR}
LICENSE="MIT"
@@ -25,7 +27,8 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
BDEPEND="
- app-arch/unzip"
+ app-arch/unzip
+"
distutils_enable_tests unittest