summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:27:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:36 +0200
commit7a806eba33702324c22ab8e1d696fdb5c15fd7c2 (patch)
tree0d7ba1df835eefc8a4ace82906b6fef68243d035 /dev-python/towncrier
parentnet-misc/electrum: Bump to 4.3.1 (diff)
downloadgentoo-7a806eba33702324c22ab8e1d696fdb5c15fd7c2.tar.gz
gentoo-7a806eba33702324c22ab8e1d696fdb5c15fd7c2.tar.bz2
gentoo-7a806eba33702324c22ab8e1d696fdb5c15fd7c2.zip
dev-python/towncrier: Bump to 22.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/towncrier')
-rw-r--r--dev-python/towncrier/Manifest1
-rw-r--r--dev-python/towncrier/towncrier-22.8.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/towncrier/Manifest b/dev-python/towncrier/Manifest
index 57628a4901fd..0f724ef6fc3d 100644
--- a/dev-python/towncrier/Manifest
+++ b/dev-python/towncrier/Manifest
@@ -1 +1,2 @@
DIST towncrier-21.9.0.gh.tar.gz 32161 BLAKE2B 9160feb1d7fa8b70350a266b91f0ebca81287ac2c25d1a586cc4db6dc64d55534e39a75aba3407fdccff83fca336cb559d21604299ecb2c01aa168e8fa75fcb2 SHA512 d58e5c9f916144085bf24fd2062bee24a1a577e283350f81bdfcd42b797fcefeece6988659b75ddc8b0701ff40a070628a548f0d4fbfb9d7c5a8c8f9cfdd29a3
+DIST towncrier-22.8.0.gh.tar.gz 47182 BLAKE2B 87674c49dc101d4e90ff3ec93b417a5e7fdc3b8b1c4adb76829789d2ee6271e2963306f3fbb2695e102f941afc0d3fcc57735b3f106eb3d9c2d1da49cb1af199 SHA512 4b404fdc7083de4807bb3a910c62a44cabde09b19807f46c255c935e8e1d5313f328785c14c845be168085bbaf9d54e3f589c6883c8a0bd2434ae46add3f6bff
diff --git a/dev-python/towncrier/towncrier-22.8.0.ebuild b/dev-python/towncrier/towncrier-22.8.0.ebuild
new file mode 100644
index 000000000000..3ac25029b5ee
--- /dev/null
+++ b/dev-python/towncrier/towncrier-22.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building newsfiles for your project"
+HOMEPAGE="
+ https://github.com/twisted/towncrier/
+ https://pypi.org/project/towncrier/
+"
+SRC_URI="
+ https://github.com/twisted/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-default-group[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/incremental[${PYTHON_USEDEP}]
+ test? (
+ dev-vcs/git
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial towncrier ||
+ die "tests failed with ${EPYTHON}"
+}