summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-01 07:09:29 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-01 07:09:29 -0400
commit75f07f24e3297f0668dfbc139befaaeabe612313 (patch)
treec4b0612f05c4fbb32c1d45631339a79b7c936d15 /dev-python/tox/tox-2.9.1.ebuild
parentsys-cluster/gearmand: Drop inactive proxied maintainer (diff)
downloadgentoo-75f07f24e3297f0668dfbc139befaaeabe612313.tar.gz
gentoo-75f07f24e3297f0668dfbc139befaaeabe612313.tar.bz2
gentoo-75f07f24e3297f0668dfbc139befaaeabe612313.zip
dev-python/tox: version bump to 2.9.1
Diffstat (limited to 'dev-python/tox/tox-2.9.1.ebuild')
-rw-r--r--dev-python/tox/tox-2.9.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/tox/tox-2.9.1.ebuild b/dev-python/tox/tox-2.9.1.ebuild
new file mode 100644
index 000000000000..90b538340dfa
--- /dev/null
+++ b/dev-python/tox/tox-2.9.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.python.org/pypi/tox"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc test"
+
+# tests need internet
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-1.11.2[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.17[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove intersphinx stuff
+ sed -i -e "s/'sphinx.ext.intersphinx',//" doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${S}"/doc/build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test || die "Testsuite failed under ${EPYTHON}"
+}