summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-17 07:37:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-17 07:56:25 +0200
commit866dbe4fa999d8cd383f3484ae1b7562ba57002a (patch)
treeefdd453c3b20375326b840762a4fefca9b6bf052 /dev-python/tox
parentdev-python/simplejson: Bump to 3.17.2 (diff)
downloadgentoo-866dbe4fa999d8cd383f3484ae1b7562ba57002a.tar.gz
gentoo-866dbe4fa999d8cd383f3484ae1b7562ba57002a.tar.bz2
gentoo-866dbe4fa999d8cd383f3484ae1b7562ba57002a.zip
dev-python/tox: Bump to 3.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.17.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 2339bf7e4c4c..86bc8e698dc2 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -2,3 +2,4 @@ DIST tox-3.15.0.tar.gz 291890 BLAKE2B 9c42c587332eafcfd02d2d8a42588af6253baf9f62
DIST tox-3.15.2.tar.gz 293523 BLAKE2B a1a1c84a987d2b2e5194321405775ee3828b8e2c8dcd38c7e780a9d508b789a42f1880cffcecd68c50dfdc37008a4e9a117660fa2c732864c82af6c2eaf5a99e SHA512 9448554452c79039289d2d2c05c974f451647329701372c3e4b154a0161fa768245c0068cd5e3f1221b4b51a07be806f7c66ab9d4ef83a3e8e5964e18b9cde85
DIST tox-3.16.1.tar.gz 294080 BLAKE2B 692ef3f498f78f239ecbb3f9ac5745462430a96bb67df7a732e5c5756d1b579c4ee8582d528d5eafddc7b19905057c01514cccaa42d7c1a442ac24cd531a656f SHA512 83fefc4b82fb33adbf2ece9a6fd6ffaf27771ac6076af5d2939dcbf68f1dd88b8edd0a105b0ec86dc7ee37b127d27ed46748af61423811c7435d0093d2e8e1eb
DIST tox-3.17.0.tar.gz 294481 BLAKE2B a4fe4c94616d003f348b2c4a58276a93887f479a3727fac3734f998071a03cd3c8da2e3b1c3bc27f0695b9d596c6d966e6c591506ce1b6ebbb5b0826c3dc20b7 SHA512 0a04b1fde7a8f7eaa24823bba59dc25c3bc48c7159866f85131bb55c0adb61d21e8c5bf88598fbbd09de58bdc51cd740d256802549e3566565af400ef7e1e95e
+DIST tox-3.17.1.tar.gz 294492 BLAKE2B 1a2ed9a26ad366a1ae7343289b45a338a8d2a58c1b6df2aaf716a2e8bbcc1cbc797c70fb51665411cf1bb69243aa8415f7fb7c82d78afb2ffb7117e4ae75edad SHA512 b084d4552609c90d006573dc95d46d0b27cf53c40a54465040e3c625b5d33eb19f95f3fa488439f11029e30ca414ce4e9ed6793a44072023826bc1f4398aaeeb
diff --git a/dev-python/tox/tox-3.17.1.ebuild b/dev-python/tox/tox-3.17.1.ebuild
new file mode 100644
index 000000000000..499658c518d4
--- /dev/null
+++ b/dev-python/tox/tox-3.17.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ =dev-python/tox-${PV}-${PR}[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # broken without internet
+ sed -i -e 's:test_provision_non_canonical_dep:_&:' \
+ tests/unit/session/test_provision.py || die
+ sed -i -e 's:test_provision_interrupt_child:_&:' \
+ tests/integration/test_provision_int.py || die
+ # broken with our mock version (?)
+ sed -i -e 's:test_create_KeyboardInterrupt:_&:' \
+ tests/unit/test_venv.py || die
+ # broken with Gentoo Python layout
+ sed -i -e 's:test_tox_get_python_executable:_&:' \
+ -e 's:test_find_alias_on_path:_&:' \
+ tests/unit/interpreters/test_interpreters.py || die
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv --no-network || die "Testsuite failed under ${EPYTHON}"
+}