summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-03 09:00:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 12:24:10 +0200
commitb0223b0898a01fccce9d5bd138c9346ae442382e (patch)
tree2a65aa0321e70b79ce59f8af2096d5018c34ec7e /dev-python/tox
parentdev-python/pytest-xdist: Bump to 1.32.0 (diff)
downloadgentoo-b0223b0898a01fccce9d5bd138c9346ae442382e.tar.gz
gentoo-b0223b0898a01fccce9d5bd138c9346ae442382e.tar.bz2
gentoo-b0223b0898a01fccce9d5bd138c9346ae442382e.zip
dev-python/tox: Bump to 3.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.15.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 3df077b0ec5d..496932953f6c 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -3,4 +3,5 @@ DIST tox-3.12.1.tar.gz 283964 BLAKE2B b7cb2394a721f281552d1f614a6059f7025390a4ea
DIST tox-3.14.4.tar.gz 289600 BLAKE2B 413782a524b70b4e301f5a4bda9c763dc7e670d7fe7785ce288b54d8a4940db0b8fed5f075c3f2cdea1d2242e35fa50765de1cd5ea544d1f433faa9a31894d61 SHA512 94e71d06ea62c275651e574359ffa224702eb4062398b44dff9504ce9e55df94d9227fc7cdbf02bc3d44244c29f29b8d3bdef3a66d94ad2dba6971860444ae7d
DIST tox-3.14.5.tar.gz 290075 BLAKE2B 7e412e85981fe11cba4dc6a4ab3df824678b11fe59bd7d909361029f30e407ffe62a24967e5a447cc643500dfb61326d47fb276bb669311780ac49aa2075fe09 SHA512 cbd0e4c53bb82a302016f380a246e9a9630b8f0c6631195af2dfa12c090cc76c3d9da8362e11c42e74bacbb3f9be504eb67e07de1d2cbac7b5f05341ea2970c4
DIST tox-3.14.6.tar.gz 290396 BLAKE2B e71efc910adcbb3e80d8945aac248541edbba04e3309b008a5cc67d0d93d9b8676d249c45e82e2c91c2c17946e0cc8f71be7714da2d9ac6651816e4f8f262be0 SHA512 0f517141db52bfc5a728e102dcaaa95a88b21a669c59e730376953f8d14b3d162e0b49272fb4078e90aa6f4244c91caaaec9fdf31497331f26d58861762a8dcc
+DIST tox-3.15.0.tar.gz 291890 BLAKE2B 9c42c587332eafcfd02d2d8a42588af6253baf9f62e82eb8a8bf10da291b4868b1fe319e38a583bc67bb26ab868b8a123feccd5bd008ce618ceb46d3121c68d2 SHA512 cb21574301d953b361eb5e1d89eefe22e68ae5871036f03d5753ee97c888cadde548d62a50622dd65b3c488143bbbdf8d309bafa3b6a4807871c9e78b6fcdb9c
DIST tox-3.2.1.tar.gz 268827 BLAKE2B 764835d04fb0c17f32eb8e2041b83f90d6a729b781a5b5b95e9ecb1162f1c29ed595d4a6369524b390a31853b8003485b27a3a12d63e84f49e92675f1a9bee13 SHA512 79f5a1c8f6e818fbb8444754e3767d880fc1fdfe63b46c518d37440fe2b2f3ce572865aff83d9492c24486fded49893cc31bd9b11254bac4db507260304bc76f
diff --git a/dev-python/tox/tox-3.15.0.ebuild b/dev-python/tox/tox-3.15.0.ebuild
new file mode 100644
index 000000000000..17f2cb7f0ce0
--- /dev/null
+++ b/dev-python/tox/tox-3.15.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ <dev-python/flaky-4
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-mock-2.0[${PYTHON_USEDEP}]
+ =dev-python/tox-${PV}-${PR}[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.9.0-strip-setuptools_scm.patch"
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # broken without internet
+ sed -i -e 's:test_provision_non_canonical_dep:_&:' \
+ tests/unit/session/test_provision.py || die
+ sed -i -e 's:test_provision_interrupt_child:_&:' \
+ tests/integration/test_provision_int.py || die
+ # broken with our mock version (?)
+ sed -i -e 's:test_create_KeyboardInterrupt:_&:' \
+ tests/unit/test_venv.py || die
+ # broken with Gentoo Python layout
+ sed -i -e 's:test_tox_get_python_executable:_&:' \
+ -e 's:test_find_alias_on_path:_&:' \
+ tests/unit/interpreters/test_interpreters.py || die
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv --no-network || die "Testsuite failed under ${EPYTHON}"
+}