summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-04 14:11:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-04 14:11:09 -0800
commiteab936c6d9c2a2a5096b29acce7a435ba70f240f (patch)
treefacc0d66cbd458445a9f0dd8aa827f64b89e6723 /dev-python/tqdm/tqdm-9999.ebuild
parentdev-python/requests-toolbelt-0.9.1: add py38 (diff)
downloadgentoo-eab936c6d9c2a2a5096b29acce7a435ba70f240f.tar.gz
gentoo-eab936c6d9c2a2a5096b29acce7a435ba70f240f.tar.bz2
gentoo-eab936c6d9c2a2a5096b29acce7a435ba70f240f.zip
dev-python/tqdm: bump to 4.40.0, add py38, sync 9999
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/tqdm/tqdm-9999.ebuild')
-rw-r--r--dev-python/tqdm/tqdm-9999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/dev-python/tqdm/tqdm-9999.ebuild b/dev-python/tqdm/tqdm-9999.ebuild
index 9a0b9b8ea059..78874a4508fc 100644
--- a/dev-python/tqdm/tqdm-9999.ebuild
+++ b/dev-python/tqdm/tqdm-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
inherit distutils-r1
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/tqdm/tqdm"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~sparc ~x86"
fi
DESCRIPTION="Add a progress meter to your loops in a second"
@@ -20,20 +20,28 @@ HOMEPAGE="https://github.com/tqdm/tqdm"
LICENSE="MIT"
SLOT="0"
-IUSE="examples test"
+IUSE="examples"
-# Uses pkg_resources
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -r \
+ -e "s:'nose'(,[[:space:]]*|)::" \
+ -e "s:'flake8'(,[[:space:]]*|)::" \
+ -e "s:'coverage'(,[[:space:]]*|)::" \
+ -i setup.py
+
+ distutils-r1_python_prepare_all
+}
python_test() {
# tests_main.py requires the package to be installed
distutils_install_for_testing
# Skip unpredictable performance tests
- nosetests tqdm -v -I 'tests_perf.py' \
+ nosetests tqdm -v --ignore 'tests_perf.py' \
|| die "tests failed with ${EPYTHON}"
}