summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-25 20:45:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-25 21:00:19 +0100
commit248b691a46d0ccab9962b0f811a8eaad02d8d7b0 (patch)
treebdf17e3f7c7248f45ccd9f40ffe057abc7084b82 /dev-python/tqdm
parentapp-backup/duplicity: remove obsolete version (diff)
downloadgentoo-248b691a46d0ccab9962b0f811a8eaad02d8d7b0.tar.gz
gentoo-248b691a46d0ccab9962b0f811a8eaad02d8d7b0.tar.bz2
gentoo-248b691a46d0ccab9962b0f811a8eaad02d8d7b0.zip
dev-python/tqdm: Bump to 4.58.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.58.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 252e8ae99ba7..c5918dd5ec6c 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,4 @@
DIST tqdm-4.55.2.tar.gz 162632 BLAKE2B 02e49f442c8d5ad3799de143dd8a188796293253e836c24d04e75aa45f7cbeecb967f1503467ca7486dfd412538da6f7a3aa4c674e16f0da3954f44347c5a498 SHA512 f61f28f2b8f7c4d848e31a3d791822a0433573b36aa900d055e1919b555b84ee36d988c6f51d6951355e70821f4d24bee72bdd4472262ea55ea012ff0556b0df
DIST tqdm-4.56.2.tar.gz 167040 BLAKE2B c1754cb262977688365c6bf17ec6b6ec31704cdb22aaf05261653c4c9609bdbd16863a15f58a7fe0fb2c0983513b091be55dbca48a0a7b1177a4d017d6800ce0 SHA512 8e7ec199c43a3cdb69bdbfaaec33c11ce8b337255eff4ae6af9928c2a2c5adb065698538562020c9f0a29a63671cbbfcf2c4c9ccb25bec0ec1d8ae8df66516c3
DIST tqdm-4.57.0.tar.gz 167590 BLAKE2B 30852febdcb69d1f0c6a7416ec7611a79896d643e18c658bb19e52196b4998d8ff9ef708c92d09d9804d8c0210b378dc8a3d58ef2b788a65835cd95ddf3406e4 SHA512 5393ffe6cbb5b41a3c51efdd14169936fcae9dd635b7a35d64f44157f2c855914dbd5c8aa933c4830a16867c83a73c0734e0ebee548392d2c73cae4e6aba531f
+DIST tqdm-4.58.0.tar.gz 167844 BLAKE2B 9a28aa91b330714f6f4d178ca793f9bc1ce5988417b38dc5a9af06c36b8949d0f23de846bc1fb87f7dac2a3b09028c4d216659f84a8ce2125de0a7870d8bc4b4 SHA512 a97a7fc1d5a181d326e91bd017cf9737fd2322f375b8efe5e53c8e49c7986edcdea39086f5057a6d2584a16e2a45b5a679055ba08c83d813fff0a61050b71b45
diff --git a/dev-python/tqdm/tqdm-4.58.0.ebuild b/dev-python/tqdm/tqdm-4.58.0.ebuild
new file mode 100644
index 000000000000..0bf4e4570b83
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.58.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ pytest -vv --ignore 'tests/tests_perf.py' ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}