summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 20:34:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 20:37:47 +0200
commitd1c79394ff4a0b8823294574220e077127cc0c3c (patch)
tree6f741d83da72226a07829ae931c0565235543de0 /dev-python/tqdm
parentdev-python/pylast: Bump to 4.0.0 (diff)
downloadgentoo-d1c79394ff4a0b8823294574220e077127cc0c3c.tar.gz
gentoo-d1c79394ff4a0b8823294574220e077127cc0c3c.tar.bz2
gentoo-d1c79394ff4a0b8823294574220e077127cc0c3c.zip
dev-python/tqdm: Bump to 4.50.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.50.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 8f2e3b0cb996..419c55bfbd1b 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1,3 @@
DIST tqdm-4.48.2.tar.gz 148978 BLAKE2B 2423a3d23b86ec6b535a2157d0fbaea6921f95873fb2507a08ff57de0fdcf8fcbfb030210393f5410437ee9977da3ad2011f07a866b3f91a057e338082325976 SHA512 849e4dad4bd0819b328e906af8a8f7acf2ebfd559c9ae3ebf822bc64c1b1a5c96e44b9b69d3dedf6387c44cf9eed559f1377ea29f71fadfc8f056c52685425e9
DIST tqdm-4.49.0.tar.gz 151935 BLAKE2B 790e2912a402795af9aba2e4db80cf41a7cb08267dad5946d89b4d9fb8b8c7a1dd65f33dcaf315bbe82862c0c2934b2dd2b8cee894c592d5a61ac61dd8c5126f SHA512 44197eb09b90551eb66c8b2e0dc97f6864fc91654465e7d478ece6ecd610242d8e378c6814f9d3e1cf05b2db1aa533743535051ad456ec5ef6d477be906ee217
+DIST tqdm-4.50.1.tar.gz 153435 BLAKE2B 5dda14bc4007e2820dc1899d352dccfd72988ce0ec84b556404d4a92f13cf51f340b7e745c39d01076485adcc6331eaf86e49c37d441ab667e4ee9e07019b238 SHA512 4db3ab73ca387961e0522fb5521bbad0420f1cf99a38a5192f048e08a30aeddd20d39ca2d7cd24dbd29e2342018fe65d55a2d0b275d188bf41f7592b8b77cd32
diff --git a/dev-python/tqdm/tqdm-4.50.1.ebuild b/dev-python/tqdm/tqdm-4.50.1.ebuild
new file mode 100644
index 000000000000..27373f57ea4f
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.50.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -r \
+ -e "s:'nose'(,[[:space:]]*|)::" \
+ -e "s:'flake8'(,[[:space:]]*|)::" \
+ -e "s:'coverage'(,[[:space:]]*|)::" \
+ -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests_main.py requires the package to be installed
+ distutils_install_for_testing
+ # Skip unpredictable performance tests
+ nosetests tqdm -v --ignore 'tests_perf.py' \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}