summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-25 18:19:49 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-25 19:49:20 +0100
commitd801c938b001736fb31aa0e078e495ea956f647c (patch)
tree83d3c54c242f2130eec42f8ffbe76ddd01778bfc /dev-python/tqdm
parentdev-python/ifaddr: Mark not-ALLARCHES (diff)
downloadgentoo-d801c938b001736fb31aa0e078e495ea956f647c.tar.gz
gentoo-d801c938b001736fb31aa0e078e495ea956f647c.tar.bz2
gentoo-d801c938b001736fb31aa0e078e495ea956f647c.zip
dev-python/tqdm: Bump to 4.55.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.55.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 34077dd5b676..88082d74b19f 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,4 @@
DIST tqdm-4.53.0.tar.gz 179940 BLAKE2B 022fd8eae70a38306d201981bd6c2e469791abc86e3e10bf2bcbe4936e4e6791dc24b3e064c6adb830fd908a1544389fdba8f7017bee17632925c1bcc3d42349 SHA512 ffb06058a71e31497ced0b6b5ce8671a7e958968e0a08e1b68dc9f3a9acac415c1708f6669d369ab484bbc07a8fc06716ed32fde70f22c0dbd8242417f95a713
DIST tqdm-4.54.0.tar.gz 178664 BLAKE2B 68d0f054b2c95079e13ad9df3e9467f48925311151e5eed94795d3fab232301da99c2704daafd80f748037a467d25416913f0921d6b7c44d725c5ed6861fe347 SHA512 dbb2a61df848ebd84ab805134b7e7297e1cf7626abaa830a08159ce7b1852eba40a6a7f2cc7c8445294a184bbfbd69bf08430371f3e2d71f6a622a271ba49e95
DIST tqdm-4.54.1.tar.gz 178633 BLAKE2B 10a9314405f1565a130baaef3b4d23fb8606b954fb6e70ec1fffd21a531957432254d3081085f8cb2e55ab103ac17ad23683a5a945917e278fcc61760ee69b90 SHA512 ba9dde2bd2f39d10bfdb0f624f1e60db12fef79732aee1fa21049e37ab60ffafbe097ab124bb3fbd34d9f4efa10e317ab7d594551ae612c0f6c37c2ce9395997
+DIST tqdm-4.55.0.tar.gz 161594 BLAKE2B 890bbb47db356678be2c3edd893d70b085f5bc8fefbf87f12ba8c69fe14ac523a1eed6e335fb84f2ff43b2b0fea901411f8a72b24212cb2ad5ef4955ec8f2df5 SHA512 84062f7d2a109e4067e0868990b6e53578c7c2ec2b81a0cbdc980c91d2d82a8bda37e0c9688777fcf14cc80b7ddf7b28b7a5acfe37608e37903fe45908103913
diff --git a/dev-python/tqdm/tqdm-4.55.0.ebuild b/dev-python/tqdm/tqdm-4.55.0.ebuild
new file mode 100644
index 000000000000..bfed1d06c33e
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.55.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ pytest -vv --ignore 'tests/tests_perf.py' ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}