summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 08:35:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:27 +0200
commitf6c4baaa2e79bab0638db0719bc09940d18f0741 (patch)
tree0c48d23224336f0cbaf30081f02e1314f3247964 /dev-python/tqdm
parentnet-proxy/haproxy: Cleanups and version bump to 2.2.13 (diff)
downloadgentoo-f6c4baaa2e79bab0638db0719bc09940d18f0741.tar.gz
gentoo-f6c4baaa2e79bab0638db0719bc09940d18f0741.tar.bz2
gentoo-f6c4baaa2e79bab0638db0719bc09940d18f0741.zip
dev-python/tqdm: Bump to 4.60.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.60.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index fb6585fc6c58..b1d1eacd537c 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.59.0.tar.gz 168620 BLAKE2B 0e3467c777d36bcfaa9f004a587bff70f171cfd7ecdca46d3a6f894afa3694873b7c50c860da31b0147f3233bb419e0c74762797d64e79b938bea813f8a38b92 SHA512 be7ffe2f5e28dd2c653fdafd26cdfab6c89f1fd257420f9ab47460230318183b4934370261d7d5939d05f55b907e2d3982cbef078d372d9a4167e1df42c895a8
+DIST tqdm-4.60.0.tar.gz 174201 BLAKE2B 78f4e2c2189621b5d276b8a9c75bae1566b05888cce81d8281de358ad2817e9751395bcf529c07620cd1ec4431c78ed7c1400dc96e9c3a99ac92daf2551b2da5 SHA512 e76dda97323353725c8e30b254bacfa328b4708d37ba2d21dadd30fd26e76605d8f077f02f2047030c6ab9761710a0e86640153fee0e3a3f972db12266fcfde2
diff --git a/dev-python/tqdm/tqdm-4.60.0.ebuild b/dev-python/tqdm/tqdm-4.60.0.ebuild
new file mode 100644
index 000000000000..0dadeb0d6b7b
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.60.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}