summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 10:30:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 10:34:47 +0200
commit6e8261a0f62e4254aaeea3ab255e595adf66f9d7 (patch)
treea91a434769cb7ce30d2a1b4b05906a53dd6e5e96 /dev-python/traitsui/traitsui-4.5.1.ebuild
parentdev-python/apptools: Version Bump (diff)
downloadgentoo-6e8261a0f62e4254aaeea3ab255e595adf66f9d7.tar.gz
gentoo-6e8261a0f62e4254aaeea3ab255e595adf66f9d7.tar.bz2
gentoo-6e8261a0f62e4254aaeea3ab255e595adf66f9d7.zip
dev-python/traitsui: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/traitsui/traitsui-4.5.1.ebuild')
-rw-r--r--dev-python/traitsui/traitsui-4.5.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/traitsui/traitsui-4.5.1.ebuild b/dev-python/traitsui/traitsui-4.5.1.ebuild
new file mode 100644
index 000000000000..569d9ac7e082
--- /dev/null
+++ b/dev-python/traitsui/traitsui-4.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable user interfaces"
+HOMEPAGE="https://github.com/enthought/traitsui"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/pyface[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+ use examples && EXAMPLES=( examples )
+ distutils-r1_python_install_all
+}