summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 22:47:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 23:00:02 +0200
commita498777f95ccc84248fcce0ae202ac7dd2ca0fb0 (patch)
treef6b1100dc54e0cbd4024157635f99c959e3fc27b /dev-python/transitions/transitions-0.8.9.ebuild
parentdev-python/dogpile-cache: Bump to 1.1.4 (diff)
downloadgentoo-a498777f95ccc84248fcce0ae202ac7dd2ca0fb0.tar.gz
gentoo-a498777f95ccc84248fcce0ae202ac7dd2ca0fb0.tar.bz2
gentoo-a498777f95ccc84248fcce0ae202ac7dd2ca0fb0.zip
dev-python/transitions: Bump to 0.8.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/transitions/transitions-0.8.9.ebuild')
-rw-r--r--dev-python/transitions/transitions-0.8.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/transitions/transitions-0.8.9.ebuild b/dev-python/transitions/transitions-0.8.9.ebuild
new file mode 100644
index 000000000000..b0e276abfbff
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ use examples && dodoc examples/*.ipynb
+}