summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-02-04 17:44:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-02-04 18:48:25 +0100
commit6826bf098a06ffdb46480b2997d0ff45d5a9d82a (patch)
tree0c48e51f58bf0e864ab17e7232b6836e6504c46d /dev-python/transitions
parentapp-benchmarks/stress-ng: drop old version (diff)
downloadgentoo-6826bf098a06ffdb46480b2997d0ff45d5a9d82a.tar.gz
gentoo-6826bf098a06ffdb46480b2997d0ff45d5a9d82a.tar.bz2
gentoo-6826bf098a06ffdb46480b2997d0ff45d5a9d82a.zip
dev-python/transitions: bump to version 0.7.2
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/Manifest1
-rw-r--r--dev-python/transitions/transitions-0.7.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
index 1e38264ce1b2..da422acf12db 100644
--- a/dev-python/transitions/Manifest
+++ b/dev-python/transitions/Manifest
@@ -1 +1,2 @@
DIST transitions-0.7.1.tar.gz 1283833 BLAKE2B 5f2f2813ba158cf5ccac4e2d55700149b986bdd24f9e864cec8d03390724cf79d9d379afa06b1a7b56c6a91376410252fdda169024f6ebbba2ed976fe7a18e7b SHA512 3fe5989faf9dbfdc15d50beaf2656240317f00278727271e5bd64ad465be1640b67e760fb73f4b06a61920343215815a8be03d41dc4d32086222446463ef71d7
+DIST transitions-0.7.2.tar.gz 1284500 BLAKE2B 12f45023f2ac1d2d3cee520f8b3618224abb69264ba4a2a7d7bb9db633328bad3cf6c9c5006e2040dc53792ab457e04aa51c9b3c54dada9ca40b845a81c40494 SHA512 2c2b083fd07c84b5e3e0a7848f54438f19234f9d54a5fd7a09b4df6bdb624ef5cf9cf59e66463b27547b9a2002fff7eefb4aae0d49b7b620edfe349688f7cf22
diff --git a/dev-python/transitions/transitions-0.7.2.ebuild b/dev-python/transitions/transitions-0.7.2.ebuild
new file mode 100644
index 000000000000..60c72178daaa
--- /dev/null
+++ b/dev-python/transitions/transitions-0.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}