summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-03 14:33:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-05 21:18:54 +0100
commit8ca292144b066868443d6a7178f6f244eb7711c1 (patch)
treeedf4afa6a6e04fbd0f0e86dbbc01b882579d9632 /dev-python/trimesh/trimesh-4.0.8.ebuild
parentpython-utils-r1.eclass, distutils-r1.eclass: Add EPYTEST_TIMEOUT (diff)
downloadgentoo-8ca292144b066868443d6a7178f6f244eb7711c1.tar.gz
gentoo-8ca292144b066868443d6a7178f6f244eb7711c1.tar.bz2
gentoo-8ca292144b066868443d6a7178f6f244eb7711c1.zip
dev-python/trimesh: Use EPYTEST_TIMEOUT
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34605 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh/trimesh-4.0.8.ebuild')
-rw-r--r--dev-python/trimesh/trimesh-4.0.8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/trimesh/trimesh-4.0.8.ebuild b/dev-python/trimesh/trimesh-4.0.8.ebuild
index 4a40c4a6730c..a0760cd1d5cb 100644
--- a/dev-python/trimesh/trimesh-4.0.8.ebuild
+++ b/dev-python/trimesh/trimesh-4.0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -46,16 +46,16 @@ RDEPEND="
BDEPEND="
test? (
dev-python/mapbox_earcut[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
)
"
+EPYTEST_TIMEOUT=900
EPYTEST_XDIST=1
distutils_enable_tests pytest
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout --timeout=900
+ epytest
}
pkg_postinst() {