summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 21:48:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:30:04 +0100
commit855e11fdb7e909a4ed06523fba973a085f1a0ab9 (patch)
tree1a6b5734345fc4586a1cc3c242df2555d1686e60 /dev-python/trimesh
parentdev-python/txaio: Bump to 22.2.1 (diff)
downloadgentoo-855e11fdb7e909a4ed06523fba973a085f1a0ab9.tar.gz
gentoo-855e11fdb7e909a4ed06523fba973a085f1a0ab9.tar.bz2
gentoo-855e11fdb7e909a4ed06523fba973a085f1a0ab9.zip
dev-python/trimesh: Bump to 3.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.10.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 7110b29f56c2..2d73cf00cd0e 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-3.10.0.tar.gz 10736418 BLAKE2B 9e65e9e5bc3984d1dca5c5d4a0498ff1f6357760a2337091a07953572c057a1807903f1a412246472f71d7fa344532ed13a8082b91de56be6c5b22d473a24e70 SHA512 33db340d8b840d4771f3d09b0529e311cdb3712a4eb43b9090a47b557632b2e97ac61ae2fed0e5ebc3da27574eb03ff96e1af1c52b2758dbcb8ae1e37737b5b7
DIST trimesh-3.10.1.tar.gz 10738596 BLAKE2B 9dc310b3e2b26fcf85f8c15841e5db1cf0edfb52593b3d89ee7ccb0678df2e9261f79cc9ed6709b5cad2ed633b220daa4f0fcb88da27bd942d1973d89968f147 SHA512 555777569c5bbfda2b93cc52ec21dfb9efecda30f3c0283415249a742b3717df8dcea9ce9cf79e42419d1bdafcad34795dd198f80b5e8a791f7cfb1a9cc2a17a
+DIST trimesh-3.10.2.gh.tar.gz 10738967 BLAKE2B 70aecc2d7524eec7eb5499f2926072139bab26cadd24a7f2200975ba1d15d7ee2a264efa124be69669f70c2a3026aa67ff3c6f56156dbf940027b48b57de4f9f SHA512 3fed75b26187dc8b682e7befd7c23c96a33cb3375255a26b3c80513d8ea9b2308f7570940a8c11da1455bd7acf5b89aead65a9743d76d2adf8e6faf5260a6b77
diff --git a/dev-python/trimesh/trimesh-3.10.2.ebuild b/dev-python/trimesh/trimesh-3.10.2.ebuild
new file mode 100644
index 000000000000..85b8a690859d
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.10.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="https://trimsh.org/ https://github.com/mikedh/trimesh"
+# No tests in PyPI tarballs
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}