summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-18 08:40:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-18 09:54:40 +0200
commit8b46520dbfe9ac80bd6c97e7bb99e92e0a656287 (patch)
treef14f8b2c0d0a1ca6dd9593e96828c0d376ed36f9 /dev-python/trimesh
parentdev-python/python-evdev: Bump to 1.6.0 (diff)
downloadgentoo-8b46520dbfe9ac80bd6c97e7bb99e92e0a656287.tar.gz
gentoo-8b46520dbfe9ac80bd6c97e7bb99e92e0a656287.tar.bz2
gentoo-8b46520dbfe9ac80bd6c97e7bb99e92e0a656287.zip
dev-python/trimesh: Bump to 3.12.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.12.9.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 1ac5ddd4f22e..fc063c8c4db9 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-3.12.7.gh.tar.gz 10756892 BLAKE2B af1f40b5de1eb60ec3241d342b3ed99fc7dc5e906c71a7669578e539d7c45ab4b037038423efb324cc462dc34a8ac1d1a8134f6b775f1965f2512acd76a8af14 SHA512 35f8039e46f55a3b2e713249d66a658ef48eb8c4a0a6e196f34933fc28052ad0a73953cc4736377bb7b79606ea08b78b132bb9d709fc50da11b2e96aa0e231e6
DIST trimesh-3.12.8.gh.tar.gz 10758444 BLAKE2B d26fa059d4015bd8b1185665d00da619471908d60dd612a6e761a2334b4f78d21bda5bc25f469be23185964f8b068977208a4e7b41591b20f7669c8f193e926d SHA512 ea6ff5577a72dc56ce89076cdee942b41866ce7bdef1971f86ec680e0ae34fad8c7038741a4a19cb83d355891d415b5e88561ae83ae13d0fc2448c08e06b2ba8
+DIST trimesh-3.12.9.gh.tar.gz 10757706 BLAKE2B a81e01a665a2a80a6a8f5b8bfcd8eb92f4dacb0a62b63209afccde48bea4dc31e05eeef8abcd40f01844cab1c9b7fe644b322c9761257be3f6abdb1858356c88 SHA512 55f9830b7f9016dc9827f5b852e035fa36ce0dafb69618fee627395c12fe40db58ea400d8c66981a313dd9a3293d538d5a0dec1c107e9bbbe691295b1a1f5fc7
diff --git a/dev-python/trimesh/trimesh-3.12.9.ebuild b/dev-python/trimesh/trimesh-3.12.9.ebuild
new file mode 100644
index 000000000000..11e1a73dfac5
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.12.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}