summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 10:40:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 10:45:05 +0200
commit84c0461f155282edcb097156914767b4fac4d36e (patch)
tree12f77e3344ba52f22f08fed7853e5b81b7c0bd7a /dev-python/trio
parentdev-python/trio: Remove optional test dep on dev-python/ipython (diff)
downloadgentoo-84c0461f155282edcb097156914767b4fac4d36e.tar.gz
gentoo-84c0461f155282edcb097156914767b4fac4d36e.tar.bz2
gentoo-84c0461f155282edcb097156914767b4fac4d36e.zip
dev-python/trio: Fix tests
Closes: https://bugs.gentoo.org/834954 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/trio-0.20.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/trio/trio-0.20.0.ebuild b/dev-python/trio/trio-0.20.0.ebuild
index 07ef1e108cee..22ac3caa37a2 100644
--- a/dev-python/trio/trio-0.20.0.ebuild
+++ b/dev-python/trio/trio-0.20.0.ebuild
@@ -38,6 +38,9 @@ EPYTEST_DESELECT=(
# Times out on slower arches (ia64 in this case)
# https://github.com/python-trio/trio/issues/1753
trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
)
EPYTEST_IGNORE=(
@@ -54,5 +57,6 @@ distutils_enable_sphinx docs/source \
dev-python/towncrier
python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -m "not redistributors_should_skip"
}