summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 10:15:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 10:45:03 +0200
commit9ba8a004073c90f734ac62a333ff5403d89a6bc6 (patch)
treed4e125637748c4e1e1a319d4777a04f90ebf515e /dev-python/trio
parentnet-misc/kafka-bin: Add support for java-11 (diff)
downloadgentoo-9ba8a004073c90f734ac62a333ff5403d89a6bc6.tar.gz
gentoo-9ba8a004073c90f734ac62a333ff5403d89a6bc6.tar.bz2
gentoo-9ba8a004073c90f734ac62a333ff5403d89a6bc6.zip
dev-python/trio: Remove unused deps on jedi & pylint
The jedi and pylint dependencies are used in one test only, and the ebuild has been skipping this test anyway. While at it, skip it using upstream marker instead of explicitly by name. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/trio-0.20.0.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-python/trio/trio-0.20.0.ebuild b/dev-python/trio/trio-0.20.0.ebuild
index 5611597d176c..de63f002d01d 100644
--- a/dev-python/trio/trio-0.20.0.ebuild
+++ b/dev-python/trio/trio-0.20.0.ebuild
@@ -32,8 +32,6 @@ BDEPEND="
>=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
>=dev-python/immutables-0.6[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
)
"
@@ -41,11 +39,6 @@ EPYTEST_DESELECT=(
# Times out on slower arches (ia64 in this case)
# https://github.com/python-trio/trio/issues/1753
trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
-
- # Fail with Python 3.10 on 'IPPROTO_MPTCP'
- # Everything else passes and this is a simple check for exported symbols
- # Let's try again with the next release (after 0.19.0).
- trio/tests/test_exports.py::test_static_tool_sees_all_symbols
)
EPYTEST_IGNORE=(
@@ -56,7 +49,11 @@ EPYTEST_IGNORE=(
distutils_enable_tests pytest
distutils_enable_sphinx docs/source \
- dev-python/immutables \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+
+python_test() {
+ epytest -m "not redistributors_should_skip"
+}