summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 15:14:52 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:36:24 +0200
commit6cc4c9a7fbb878eb18e264797a6efe1b63d8c1fd (patch)
tree8aee00065c47a426da8ea9de79ecb92e8d24ebbf /dev-python/trollius/trollius-2.2.ebuild
parentdev-python/pycares: Bump to 3.0.0_p20190709 (diff)
downloadgentoo-6cc4c9a7fbb878eb18e264797a6efe1b63d8c1fd.tar.gz
gentoo-6cc4c9a7fbb878eb18e264797a6efe1b63d8c1fd.tar.bz2
gentoo-6cc4c9a7fbb878eb18e264797a6efe1b63d8c1fd.zip
dev-python/trollius: Bump to 2.2, remove py3 support
Bump to the last release which marks the project deprecated. Remove py3 support since the package has no usefulness for py3, py3.6 fails tests and py3.7 is entirely broken. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trollius/trollius-2.2.ebuild')
-rw-r--r--dev-python/trollius/trollius-2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/trollius/trollius-2.2.ebuild b/dev-python/trollius/trollius-2.2.ebuild
new file mode 100644
index 000000000000..9de2fd0afd5d
--- /dev/null
+++ b/dev-python/trollius/trollius-2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Port of the asyncio project to Python 2.7 (deprecated)"
+HOMEPAGE="https://github.com/vstinner/trollius https://pypi.org/project/trollius/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" runtests.py -v 2 || die "Testing failed under ${EPYTHON}"
+}