summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 12:31:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 12:46:58 +0200
commit8a0cbd08fa226dd2bd8695bea8470d3b9610e495 (patch)
tree7b2cfebe6f697200c021269e3f94756cd1a360e9 /dev-python/trustme/trustme-0.6.0-r1.ebuild
parentdev-python/brotlipy: Remove python2 (diff)
downloadgentoo-8a0cbd08fa226dd2bd8695bea8470d3b9610e495.tar.gz
gentoo-8a0cbd08fa226dd2bd8695bea8470d3b9610e495.tar.bz2
gentoo-8a0cbd08fa226dd2bd8695bea8470d3b9610e495.zip
dev-python/trustme: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trustme/trustme-0.6.0-r1.ebuild')
-rw-r--r--dev-python/trustme/trustme-0.6.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/trustme/trustme-0.6.0-r1.ebuild b/dev-python/trustme/trustme-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..37ff47546a7b
--- /dev/null
+++ b/dev-python/trustme/trustme-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="https://github.com/python-trio/trustme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest