summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-07 08:14:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-07 08:37:51 +0200
commita6ae8fb19322b1356f1af8fafce32f013842a87e (patch)
tree9c3153a6a7c3733147f0b505eafa5af0de211887 /dev-python/trustme
parentdev-python/trustme: Add python@ as co-maint (diff)
downloadgentoo-a6ae8fb19322b1356f1af8fafce32f013842a87e.tar.gz
gentoo-a6ae8fb19322b1356f1af8fafce32f013842a87e.tar.bz2
gentoo-a6ae8fb19322b1356f1af8fafce32f013842a87e.zip
dev-python/trustme: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trustme')
-rw-r--r--dev-python/trustme/Manifest1
-rw-r--r--dev-python/trustme/trustme-0.5.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/trustme/Manifest b/dev-python/trustme/Manifest
index 1b65b757f346..81546b7913bc 100644
--- a/dev-python/trustme/Manifest
+++ b/dev-python/trustme/Manifest
@@ -1 +1,2 @@
DIST trustme-0.5.0.tar.gz 21232 BLAKE2B 3804fe4e9b7049da0bab926bb1180af6bbb8f882cfb16109bed040ca50c85e7b83b5468c3388dd8478ee9fc6478523bba98c39b74cb76c86a72761a26685122e SHA512 7ce5041b8d3687fa462fe93e55b2f83549ab805cec4a2a94c9178a02af557cf8900fe6c05bae0bf100eb36181952fb2bc31cb1d4d6ad6ed2fd2b0706d569518f
+DIST trustme-0.5.2.tar.gz 21819 BLAKE2B 68516eee909851f16c092cff580b1267e57aad5641014c7e1ff5da98fc328e1e392cf0e08d1965be062f2be1c16de735ddeff2dfbb2f20b1bb34498a1b048861 SHA512 32ab33a82752228aad200203b7b217f9b9da970067330a273c9ff5c13c8ae15ef20c39e61fc9cd748b7030691ef4b003f279a50374f59b7743c4c90aeca56a22
diff --git a/dev-python/trustme/trustme-0.5.2.ebuild b/dev-python/trustme/trustme-0.5.2.ebuild
new file mode 100644
index 000000000000..ee3f8b306297
--- /dev/null
+++ b/dev-python/trustme/trustme-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="https://github.com/python-trio/trustme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' -2 )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' -2 )
+ )"
+
+python_test() {
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}