summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-09 00:51:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-09 00:51:39 +0200
commitca301a275d65135d4299fd6c7cdfdfd927af7cc7 (patch)
treeeb9e401d47ace9061e2b6a26930359d3ab0930d2 /dev-python/trustme
parentdev-python/google-api-core: Bump to 1.30.0 (diff)
downloadgentoo-ca301a275d65135d4299fd6c7cdfdfd927af7cc7.tar.gz
gentoo-ca301a275d65135d4299fd6c7cdfdfd927af7cc7.tar.bz2
gentoo-ca301a275d65135d4299fd6c7cdfdfd927af7cc7.zip
dev-python/trustme: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trustme')
-rw-r--r--dev-python/trustme/Manifest1
-rw-r--r--dev-python/trustme/trustme-0.8.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/trustme/Manifest b/dev-python/trustme/Manifest
index 508813567c33..40a418e85f8b 100644
--- a/dev-python/trustme/Manifest
+++ b/dev-python/trustme/Manifest
@@ -1 +1,2 @@
DIST trustme-0.7.0.tar.gz 27853 BLAKE2B 97313cfe10260c67e29b470b9b65d4bb190b6e3be9b6944599a3c318d87b984f44abfe581420cd0ef29afc8165029c67129104cfb7ccf9d68e3c686424de34ec SHA512 3b2aa69dc617c04af3a83ca424ef19b5eaf37495ba4bc5cc55004016a9ea63c8df3585bb7fe52709b1b18a2a55e51d6a1a2b21ebc12c57ac18133b20c958b1a8
+DIST trustme-0.8.0.tar.gz 29046 BLAKE2B 5f2dd542974466dd8e61fa0ba5cd78e824afd243dd3b27ca21aec4ba4905daaa0c46db8f4edb30dcb483acf44758d7ad8de4db9c3e07a05d4d3d084565722def SHA512 93b1007319f7d625410eddf92910607c8190533f9bb02a71ecc4c424e44ecea70749f6bceb917297241e179b0d50ce1ed330c208cf3de77d4d3a619f5436af9d
diff --git a/dev-python/trustme/trustme-0.8.0.ebuild b/dev-python/trustme/trustme-0.8.0.ebuild
new file mode 100644
index 000000000000..92cbabb2bb37
--- /dev/null
+++ b/dev-python/trustme/trustme-0.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="https://github.com/python-trio/trustme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest