summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/twilio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/twilio')
-rw-r--r--dev-python/twilio/Manifest1
-rw-r--r--dev-python/twilio/metadata.xml11
-rw-r--r--dev-python/twilio/twilio-3.6.9.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/twilio/Manifest b/dev-python/twilio/Manifest
new file mode 100644
index 000000000000..310a7ffb3e1a
--- /dev/null
+++ b/dev-python/twilio/Manifest
@@ -0,0 +1 @@
+DIST twilio-3.6.9.tar.gz 226151 SHA256 0a6ce201edaf9f79a376f2713e10f3fc9cb8b64c046b1df5d1c87c56e8ec321b SHA512 f4e0f13e3f12ae8e15817a285a4388859b458ba7759acce4d5f6ee425bd6a06742bf271a01e1cc5140d63bc599828b940f1e96a6ed7f5744c1c9eaef2dd65b29 WHIRLPOOL 95fc4864dc63a5f18a3108014aca831da36ebfb4d8ff68cd739b768e6df81c56de8a2e1f4b138f927b4c5645ad0bf2a9d1330b81e34ca0e60bf6041fbd7ddf3f
diff --git a/dev-python/twilio/metadata.xml b/dev-python/twilio/metadata.xml
new file mode 100644
index 000000000000..a38887dd69f0
--- /dev/null
+++ b/dev-python/twilio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">twilio/twilio-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/twilio/twilio-3.6.9.ebuild b/dev-python/twilio/twilio-3.6.9.ebuild
new file mode 100644
index 000000000000..66bba6f554a0
--- /dev/null
+++ b/dev-python/twilio/twilio-3.6.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Helper library for the Twilio API"
+HOMEPAGE="https://github.com/twilio/twilio-python http://www.twilio.com/docs/python/install"
+SRC_URI="https://github.com/twilio/${PN}-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+CDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/socksipy[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}"
+DEPEND="test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}