summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-05-27 14:45:17 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-07 10:16:39 +0200
commit91c7947bf425c6831c54639d284547c34a78acf6 (patch)
tree59912aeaacc91a3575eccd9d92ff526924809150 /dev-python/txAMQP/txAMQP-0.8.2.ebuild
parentdev-python/django-tagging: bump to 0.4.6, add doc, fix deps (diff)
downloadgentoo-91c7947bf425c6831c54639d284547c34a78acf6.tar.gz
gentoo-91c7947bf425c6831c54639d284547c34a78acf6.tar.bz2
gentoo-91c7947bf425c6831c54639d284547c34a78acf6.zip
dev-python/txAMQP: bump to 0.8.2 which supports Python 3
Also require Python with xml support and add bugs-to to metadata.xml. Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-python/txAMQP/txAMQP-0.8.2.ebuild')
-rw-r--r--dev-python/txAMQP/txAMQP-0.8.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/txAMQP/txAMQP-0.8.2.ebuild b/dev-python/txAMQP/txAMQP-0.8.2.ebuild
new file mode 100644
index 000000000000..2c1e1f260f11
--- /dev/null
+++ b/dev-python/txAMQP/txAMQP-0.8.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_P=${PN,,}-${PV}
+DESCRIPTION="Python library for communicating with AMQP peers using Twisted"
+HOMEPAGE="https://github.com/txamqp/txamqp"
+# pypi tarball misses doc files
+# https://github.com/txamqp/txamqp/pull/10
+SRC_URI="https://github.com/txamqp/txamqp/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+# TODO: split twisted-core gives minor test failure, get rid of it
+# when we port revdeps
+RDEPEND="
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ net-misc/rabbitmq-server
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests connect to the system rabbitmq server
+# TODO: figure out how to start an isolated instance
+RESTRICT="test"
+
+python_test() {
+ cd src || die
+ # tests look for those files relatively to modules
+ cp -r specs "${BUILD_DIR}"/lib || die
+
+ TXAMQP_BROKER=RABBITMQ trial txamqp
+ local ret=${?}
+
+ # avoid installing spec files
+ rm -r "${BUILD_DIR}"/lib/specs || die
+
+ [[ ${ret} == 0 ]] || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( doc/* )
+
+ distutils-r1_python_install_all
+}