summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 16:29:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 17:23:30 +0200
commit876d2220e0e61aa6d3a66a3afd653ce78002e2af (patch)
tree18a27231fc2df9ae6aee66c6dadad8e1a797c6c7 /dev-python/txaio
parentdev-python/snappy: Enable py3.11 (diff)
downloadgentoo-876d2220e0e61aa6d3a66a3afd653ce78002e2af.tar.gz
gentoo-876d2220e0e61aa6d3a66a3afd653ce78002e2af.tar.bz2
gentoo-876d2220e0e61aa6d3a66a3afd653ce78002e2af.zip
dev-python/txaio: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/txaio-22.2.1.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/dev-python/txaio/txaio-22.2.1.ebuild b/dev-python/txaio/txaio-22.2.1.ebuild
index 173b2c1b92f6..9b967afe9b6f 100644
--- a/dev-python/txaio/txaio-22.2.1.ebuild
+++ b/dev-python/txaio/txaio-22.2.1.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1 optfeature
DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
-HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
+HOMEPAGE="
+ https://github.com/crossbario/txaio/
+ https://pypi.org/project/txaio/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -21,11 +24,20 @@ distutils_enable_sphinx docs \
'>=dev-python/sphinx_rtd_theme-0.1.9'
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # Take out failing tests known to pass when run manually
- # we certainly don't need to test "python setup.py sdist" here
- test/test_packaging.py
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ # we certainly don't need to test "python setup.py sdist" here
+ test/test_packaging.py
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # tests for removed asyncio.coroutine
+ test/test_as_future.py::test_as_future_coroutine
+ test/test_call_later.py::test_explicit_reactor_coroutine
+ test/test_is_future.py::test_is_future_coroutine
+ )
+
+ epytest
+}
pkg_postinst() {
optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"