summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 21:45:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:30:03 +0100
commitc5ff4bd8e11edd4188b4c61d8f9fb2f23b9e7d29 (patch)
treeb430fc731b6ceb10d0f748686b4c30bcc40de1ca /dev-python/txaio
parentdev-python/ansible-runner: Bump to 1.4.8 (diff)
downloadgentoo-c5ff4bd8e11edd4188b4c61d8f9fb2f23b9e7d29.tar.gz
gentoo-c5ff4bd8e11edd4188b4c61d8f9fb2f23b9e7d29.tar.bz2
gentoo-c5ff4bd8e11edd4188b4c61d8f9fb2f23b9e7d29.zip
dev-python/txaio: Bump to 22.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/Manifest1
-rw-r--r--dev-python/txaio/txaio-22.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index 15b3b575d3cb..e5f2a880c796 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1 +1,2 @@
DIST txaio-21.2.1.tar.gz 53383 BLAKE2B ff245c7e303a88e0e0f71bfa99ec5cfa2e6ec026e43e9477beb711cc753d73d4f49079727f9f86499779819fda74747edee00ebe22c0ac59c764c1403b983960 SHA512 762875b9c10304dab31dd54f7830f56b0cc26dd6e7a98c8faf57891a2810e36f53004833f872f0f51bad61cb62be033cfc228c99fd6aff60cd4dd2ae2f2e5c37
+DIST txaio-22.2.1.tar.gz 53645 BLAKE2B 375203ddbe65d293ba0bf85e316880d552f47cbc9008bd41e50976ee097940c626ec66ad25e0b5322493f71f77141d03f543ce9c9d83268a1a896b16f434ccaa SHA512 b5e33ba671ab215dadf4c348b01e9d5057d080c21707d31e38912fe596aabd7b388e8c5e0f2dd2b7d0d09fe0a175a0906e2a2ee428c1a943e786afa79182631e
diff --git a/dev-python/txaio/txaio-22.2.1.ebuild b/dev-python/txaio/txaio-22.2.1.ebuild
new file mode 100644
index 000000000000..31b3f3d21663
--- /dev/null
+++ b/dev-python/txaio/txaio-22.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinxcontrib-spelling-2.1.2' \
+ '>=dev-python/sphinx_rtd_theme-0.1.9'
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Take out failing tests known to pass when run manually
+ # we certainly don't need to test "python setup.py sdist" here
+ test/test_packaging.py
+)
+
+pkg_postinst() {
+ optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"
+}