summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 11:57:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 12:34:08 +0200
commit5081f651371f17618716a47f4d96bb51b3c74a9c (patch)
tree52533e7b59a7de9b45cb813bde9e5e2319d13758 /dev-python/typeguard
parentdev-python/typeguard: Use PEP517 build (diff)
downloadgentoo-5081f651371f17618716a47f4d96bb51b3c74a9c.tar.gz
gentoo-5081f651371f17618716a47f4d96bb51b3c74a9c.tar.bz2
gentoo-5081f651371f17618716a47f4d96bb51b3c74a9c.zip
dev-python/typeguard: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest2
-rw-r--r--dev-python/typeguard/typeguard-2.13.0.ebuild39
-rw-r--r--dev-python/typeguard/typeguard-2.13.2.ebuild39
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index bd919f1a8b8f..1f9c43e6470b 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1,3 +1 @@
-DIST typeguard-2.13.0.gh.tar.gz 36849 BLAKE2B ef9b724bdd5ef127b6ede4ff4cb1d4f4794b0e921512d2cbf474145bf64de0cae85b7f5283dfc7f0b750e79e1c44c03ce6b4c0f24a33ae961c428aa57f3b6ae5 SHA512 48df7a9d6ee2cc11b5118432afcda5e0939712ff66d67f3945e26047c0880a05c133b505869ebcef59ce438260b9f6d1806121d0d4828853bc3b9c3468769f39
-DIST typeguard-2.13.2.gh.tar.gz 37142 BLAKE2B 0aa3f53bc0d1aa485d071cd52d2458ab83c4d5eba88708240c100a3205a2714f39465cb48d82118eb6bcf1e30579e50bb5dffb31b3f2b673573481772d650a23 SHA512 a11c1b9ee417a99a8bd09f4b5b05c7cdf319748b8221a49d1ff76854e2f432768224437f82a41c0166e5b148a550b58afbabfa1935cdc2a049cda3010edd052a
DIST typeguard-2.13.3.gh.tar.gz 37436 BLAKE2B a3cb616692119c64a9dc0d0bae25cc661b7974a0b6cf6632fa403f7c5430873570b1aaa310bc03843deee6f77a831c303ea9d9091db596eb565fce43980bbb13 SHA512 26c31ee9670650d1969320187a924d29d986894a38f1026af58f705b132b64be3b6e2ac34729f966f5d302d486334b5a5d9e65fb206245b82b0ff0852020b609
diff --git a/dev-python/typeguard/typeguard-2.13.0.ebuild b/dev-python/typeguard/typeguard-2.13.0.ebuild
deleted file mode 100644
index 9ea46fa44506..000000000000
--- a/dev-python/typeguard/typeguard-2.13.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/"
-SRC_URI="
- https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- epytest
-}
diff --git a/dev-python/typeguard/typeguard-2.13.2.ebuild b/dev-python/typeguard/typeguard-2.13.2.ebuild
deleted file mode 100644
index 9ea46fa44506..000000000000
--- a/dev-python/typeguard/typeguard-2.13.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/"
-SRC_URI="
- https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- epytest
-}