summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-11 08:43:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-11 09:56:42 +0200
commitf8605758859eab9f5814eb00b16074e39249c74d (patch)
treef996abb7fd3236e656325163f99dc48637998c9f /dev-python/typeguard
parentdev-python/pycodestyle: Bump to 2.8.0 (diff)
downloadgentoo-f8605758859eab9f5814eb00b16074e39249c74d.tar.gz
gentoo-f8605758859eab9f5814eb00b16074e39249c74d.tar.bz2
gentoo-f8605758859eab9f5814eb00b16074e39249c74d.zip
dev-python/typeguard: Bump to 2.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-2.13.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index cfe8c9dbb744..6d1aa8580741 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-2.12.1.gh.tar.gz 35894 BLAKE2B 309b5fd906ae5122fbd2134ff30f6f2908a5d64fc8510dd054a9f47feef5f1674ea6133156fb6649c85a6fc8a98609387f742e7f9588db8ab008ef2caec0c740 SHA512 ea91140ba0ebfe7cc83bf212ae20aca777279fc88ff806bf6a1f4208581bb726c6091d0777371d487e7422887814d81c84ebac9f06bfacc5a929f5a2657312a8
+DIST typeguard-2.13.0.gh.tar.gz 36849 BLAKE2B ef9b724bdd5ef127b6ede4ff4cb1d4f4794b0e921512d2cbf474145bf64de0cae85b7f5283dfc7f0b750e79e1c44c03ce6b4c0f24a33ae961c428aa57f3b6ae5 SHA512 48df7a9d6ee2cc11b5118432afcda5e0939712ff66d67f3945e26047c0880a05c133b505869ebcef59ce438260b9f6d1806121d0d4828853bc3b9c3468769f39
diff --git a/dev-python/typeguard/typeguard-2.13.0.ebuild b/dev-python/typeguard/typeguard-2.13.0.ebuild
new file mode 100644
index 000000000000..9ea46fa44506
--- /dev/null
+++ b/dev-python/typeguard/typeguard-2.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/"
+SRC_URI="
+ https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ epytest
+}