summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-14 09:04:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 09:32:31 +0100
commitf4901813fc66a6f30fd72654589e14d907aadd1b (patch)
tree0c78a717f8c0ac4bec1ae5fc3171aae85b608220 /dev-python/typing-extensions
parentmedia-video/yle-dl: add 20220213 (diff)
downloadgentoo-f4901813fc66a6f30fd72654589e14d907aadd1b.tar.gz
gentoo-f4901813fc66a6f30fd72654589e14d907aadd1b.tar.bz2
gentoo-f4901813fc66a6f30fd72654589e14d907aadd1b.zip
dev-python/typing-extensions: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typing-extensions')
-rw-r--r--dev-python/typing-extensions/Manifest1
-rw-r--r--dev-python/typing-extensions/typing-extensions-4.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/typing-extensions/Manifest b/dev-python/typing-extensions/Manifest
index e06178dcf80f..573b97b6ce0f 100644
--- a/dev-python/typing-extensions/Manifest
+++ b/dev-python/typing-extensions/Manifest
@@ -1,2 +1,3 @@
DIST typing-extensions-4.0.1.gh.tar.gz 65425 BLAKE2B 0712ac0b87e67e716c562bc8d25d88b60c42b513b7f97ddeb2b6d959f2a3ee582ec5f692a192d17323ff892290bf410eadd53012ff0485c4c8b2bc8b15a7a465 SHA512 5af1590a98247f01df5abcbc7fe4db19b0b174918d2679b532e8c1e5483ae2293901c2314240217ab1bad087633e02865311f9b295b3d65587fdf2f6e0a26bc5
DIST typing-extensions-4.1.0.gh.tar.gz 78345 BLAKE2B 535e99c40f148b84047074e7fdf3e34e47fca018e258170677cad82d4fdd821429dd13a33673841757357d4d8bc01d22eca2d409b5ee106fffa876177fbe4037 SHA512 05afc509502a1c36b50a3c0c64e1677573d7ae4fccb3f0e14497df2a655f897faeda58a6d0c529ec160e89327a865e9bd6f818a58b773f75da64c6ce2c7d0f2e
+DIST typing-extensions-4.1.1.gh.tar.gz 78687 BLAKE2B 94a486a746ff76d8ad1c416b61ec3e22864246c531536d7db6f0aa5113adf0f4bcb9e8e843b9c7fdbbbe915375fa303211d66b9f838629ac0d43a768a4bc82cc SHA512 251e7bd0216d0b2a83d963bd528d94700f113cc0ccc98959d5512faf5c738e1332673f42709ce8b3b7f5c7573edb794c34f5c02d82fef8d4bbae03db50b1ce92
diff --git a/dev-python/typing-extensions/typing-extensions-4.1.1.ebuild b/dev-python/typing-extensions/typing-extensions-4.1.1.ebuild
new file mode 100644
index 000000000000..40d1dbb27581
--- /dev/null
+++ b/dev-python/typing-extensions/typing-extensions-4.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=typing-${PV}
+DESCRIPTION="Type Hint extensions from Python 3.8 backported"
+HOMEPAGE="
+ https://pypi.org/project/typing-extensions/
+ https://github.com/python/typing/"
+SRC_URI="
+ https://github.com/python/typing/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}/typing_extensions
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+python_test() {
+ cd "${S}"/src || die
+ "${EPYTHON}" test_typing_extensions.py -v || die "tests failed under ${EPYTHON}"
+}