summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-28 20:09:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-28 20:15:23 +0200
commit4974eb40edca49042ed1dba24d28469e6d18c180 (patch)
tree5ade92f507adcb6196c1091162332686cc0812bd /dev-python/tzdata/tzdata-9999.ebuild
parentnet-analyzer/netdata: add 1.42.2 (diff)
downloadgentoo-4974eb40edca49042ed1dba24d28469e6d18c180.tar.gz
gentoo-4974eb40edca49042ed1dba24d28469e6d18c180.tar.bz2
gentoo-4974eb40edca49042ed1dba24d28469e6d18c180.zip
dev-python/tzdata: A shim package (v9999) to satisfy deps
Add a shim package that installs metadata for `tzdata` to satisfy the requirements of other packages while using system timezone-data. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tzdata/tzdata-9999.ebuild')
-rw-r--r--dev-python/tzdata/tzdata-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tzdata/tzdata-9999.ebuild b/dev-python/tzdata/tzdata-9999.ebuild
new file mode 100644
index 000000000000..5e212ace5c26
--- /dev/null
+++ b/dev-python/tzdata/tzdata-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="tzdata shim to satisfy requirements (while using system tzdata)"
+HOMEPAGE="https://peps.python.org/pep-0615/"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ sys-libs/timezone-data
+"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cat > "${S}/pyproject.toml" <<-EOF || die
+ [build-system]
+ requires = ["hatchling"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "tzdata"
+ version = "9999"
+ description = "tzdata shim to satisfy requirements (using system tzdata)"
+ EOF
+}