summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 09:15:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:13 +0200
commit987eb39b1839f484eb30d8afb301d083a9073641 (patch)
tree67308f590d50e0075265748642cc7f563a16cccd /dev-python/tzlocal
parentdev-python/google-auth: Bump to 2.3.2 (diff)
downloadgentoo-987eb39b1839f484eb30d8afb301d083a9073641.tar.gz
gentoo-987eb39b1839f484eb30d8afb301d083a9073641.tar.bz2
gentoo-987eb39b1839f484eb30d8afb301d083a9073641.zip
dev-python/tzlocal: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tzlocal')
-rw-r--r--dev-python/tzlocal/Manifest1
-rw-r--r--dev-python/tzlocal/tzlocal-4.0.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/tzlocal/Manifest b/dev-python/tzlocal/Manifest
index a1fa8cebd1e9..76bd08e23875 100644
--- a/dev-python/tzlocal/Manifest
+++ b/dev-python/tzlocal/Manifest
@@ -1,4 +1,5 @@
DIST tzlocal-2.1.gh.tar.gz 18463 BLAKE2B 73e886cfb6d13bebc1a15a222da60f368a15dc5a097acac74990b1d76bdaa229be8f12ff735d1828ccd78c4c8d06eb5bc0a07da695d70251af1e67e4fb71037e SHA512 2679cebdc2692d9e0e1c9b714994ad881896f53e75ef407229a67c9fee9d27617638a2919865cb67e21e2bbd6e3bc13f2568343037e06603236f25a96aa6863d
DIST tzlocal-3.0.gh.tar.gz 18924 BLAKE2B 340739015ce0fae245ddcb2d3f6250886261a81a49c9db7960515e178090183d3a826ee494763503023c033d3d9c19771aad865d4c1150350a118250aab23362 SHA512 9060eb325783d183bfaf7038476031a2ea22fd4ba50f6b5caf3d8eda15d9c90e557c64a0218c7e3c3df51f385378fe8a17f10871abb038012e1d05a9547918c3
DIST tzlocal-4.0.1.gh.tar.gz 22737 BLAKE2B 0b84ab7ac80397d2d72e0627d3766e1f6a6402c3d0505f0ff0fc02fc524b372a92e0fe948f1f8ec59b0ccfae64f8240bddc8800fe988627a87aec5b8937a6df9 SHA512 0e83e9cba7d74690677d32087a82a54bf1f80dde121d6eed80ca0a80851832ef197cfab07728353619904706b989bbb4c9ca1736e7e1e6c710ad4ec93f74ac22
+DIST tzlocal-4.0.2.gh.tar.gz 22978 BLAKE2B 4c1d7ed518ed6984f2dd055ab4bdeeb9acee1c2fae14160ab8752adae8cc16969ec822d0b20d2b77d40d6b52a929f44d83b2537dffbd3b7db6c016145b870ec0 SHA512 4624bfda1e712bf898a4d3a8e4be20082689caf533bc340f0dede068323a4848328e7c4a2bb0d63e4ed59258ef5f21654d47135419360f73d0bdb7c38aee2906
DIST tzlocal-4.0.gh.tar.gz 22582 BLAKE2B 35ef0b9f64e0b2758ecda19669957666ffcd807197cfef74583d94a3e2ca01811e55b27228522723dec140dd4ede69e30585d850f03f55db084d975e871d2f63 SHA512 8bb31f3d85256aaab2a803c34ea35677a25ae2bf339d54a1fb4466d035631d9f22ea465448d7905d607a17c6b1180cbc619ce06b39c3ebe724270bc048bd96ed
diff --git a/dev-python/tzlocal/tzlocal-4.0.2.ebuild b/dev-python/tzlocal/tzlocal-4.0.2.ebuild
new file mode 100644
index 000000000000..e052e465a137
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-4.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="https://github.com/regebro/tzlocal"
+SRC_URI="https://github.com/regebro/tzlocal/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pytz_deprecation_shim[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest