summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:52:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:52:19 +0200
commit43193035f7c468fcd1488df3558fb0d4c4ab38aa (patch)
treeda074c4c88aab6d185254e6477e4af65d89ec939 /dev-python/u-msgpack/u-msgpack-2.6.0.ebuild
parentdev-python/waitress: Bump to 1.4.3 (diff)
downloadgentoo-43193035f7c468fcd1488df3558fb0d4c4ab38aa.tar.gz
gentoo-43193035f7c468fcd1488df3558fb0d4c4ab38aa.tar.bz2
gentoo-43193035f7c468fcd1488df3558fb0d4c4ab38aa.zip
dev-python/u-msgpack: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/u-msgpack/u-msgpack-2.6.0.ebuild')
-rw-r--r--dev-python/u-msgpack/u-msgpack-2.6.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/u-msgpack/u-msgpack-2.6.0.ebuild b/dev-python/u-msgpack/u-msgpack-2.6.0.ebuild
new file mode 100644
index 000000000000..3bd4d2b913b0
--- /dev/null
+++ b/dev-python/u-msgpack/u-msgpack-2.6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="https://github.com/vsergeev/u-msgpack-python https://pypi.org/project/u-msgpack-python/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest