summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-08 05:57:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-08 06:37:37 +0100
commit2835033eba6ad3e366c18a04a1c06308f68db07b (patch)
tree063578814ca8424e0abc8ecb9cb2ff41a532bf48 /dev-python/ubelt/ubelt-0.10.2.ebuild
parentdev-python/cx_Freeze: Bump to 6.9 (diff)
downloadgentoo-2835033eba6ad3e366c18a04a1c06308f68db07b.tar.gz
gentoo-2835033eba6ad3e366c18a04a1c06308f68db07b.tar.bz2
gentoo-2835033eba6ad3e366c18a04a1c06308f68db07b.zip
dev-python/ubelt: Bump to 0.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ubelt/ubelt-0.10.2.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-0.10.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ubelt/ubelt-0.10.2.ebuild b/dev-python/ubelt/ubelt-0.10.2.ebuild
new file mode 100644
index 000000000000..67d4f2466be8
--- /dev/null
+++ b/dev-python/ubelt/ubelt-0.10.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/ordered-set[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)