summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 21:37:54 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 21:43:48 +0200
commit1ae7e8b361edde0647db049d04abfcc54b2e3731 (patch)
treebcff06a9b82adaeb542f0b3b1f2d5d056f6400fc /dev-python/ufoLib/ufoLib-3.0.0.ebuild
parentdev-python/backports-os: Fix metadata (diff)
downloadgentoo-1ae7e8b361edde0647db049d04abfcc54b2e3731.tar.gz
gentoo-1ae7e8b361edde0647db049d04abfcc54b2e3731.tar.bz2
gentoo-1ae7e8b361edde0647db049d04abfcc54b2e3731.zip
dev-python/ufoLib: New package needed for noto-emoji
Bug: https://bugs.gentoo.org/616974 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/ufoLib/ufoLib-3.0.0.ebuild')
-rw-r--r--dev-python/ufoLib/ufoLib-3.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ufoLib/ufoLib-3.0.0.ebuild b/dev-python/ufoLib/ufoLib-3.0.0.ebuild
new file mode 100644
index 000000000000..7ce26ab26ba6
--- /dev/null
+++ b/dev-python/ufoLib/ufoLib-3.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A low-level UFO reader and writer"
+HOMEPAGE="https://github.com/unified-font-object/ufoLib"
+SRC_URI="https://github.com/unified-font-object/ufoLib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/fs[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ dev-python/fs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}