summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 19:00:50 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 19:00:58 -0800
commit2c6657b5906908ab559020839c73cd5fd1f930c8 (patch)
treef5bafd77b28d5b336dc333afab197c3c6498a801 /dev-python/ujson/ujson-1.35-r1.ebuild
parentdev-python/qscintilla-python: add 2.11.3 (diff)
downloadgentoo-2c6657b5906908ab559020839c73cd5fd1f930c8.tar.gz
gentoo-2c6657b5906908ab559020839c73cd5fd1f930c8.tar.bz2
gentoo-2c6657b5906908ab559020839c73cd5fd1f930c8.zip
dev-python/ujson-1.35-r1: Revbump, EAPI=7, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ujson/ujson-1.35-r1.ebuild')
-rw-r--r--dev-python/ujson/ujson-1.35-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/ujson/ujson-1.35-r1.ebuild b/dev-python/ujson/ujson-1.35-r1.ebuild
new file mode 100644
index 000000000000..006979f5c980
--- /dev/null
+++ b/dev-python/ujson/ujson-1.35-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sort_keys-segfault.patch"
+ "${FILESDIR}/${P}-use-static-where-possible.patch"
+ "${FILESDIR}/${P}-fix-for-overflowing-long.patch"
+ "${FILESDIR}/${P}-standard-handling-of-none.patch"
+ "${FILESDIR}/${P}-fix-ordering-of-orderdict.patch"
+ "${FILESDIR}/${P}-test-depricationwarning.patch"
+)
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die
+}