summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:52:54 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:52:54 +0100
commit4526068ac73c0fa4ae65c75063197a8824bde127 (patch)
tree9a72b2bc77c430825cccf03c99168db1a9e4ebeb /dev-python/ujson
parentdev-python/treq: Remove old (diff)
downloadgentoo-4526068ac73c0fa4ae65c75063197a8824bde127.tar.gz
gentoo-4526068ac73c0fa4ae65c75063197a8824bde127.tar.bz2
gentoo-4526068ac73c0fa4ae65c75063197a8824bde127.zip
dev-python/ujson: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/files/ujson-1.33-test-py3.patch38
-rw-r--r--dev-python/ujson/ujson-1.33.ebuild45
3 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index c10c9b79e008..6e3b3d1940df 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1,2 +1 @@
-DIST ujson-1.33.zip 197034 BLAKE2B 587e00292340d69fdda9720d66bb360ed646f8c709e279f905f7fdf2db79a2ec51856dce998fd3e2fe5b3bf067c72ad661f77154bc3d63cee4c3eea10bca29ec SHA512 0f1f66212fbf94c03e048ba64c3bd817c50443d1a29b87f6a3a38f697a050f38821be4ba36a3b17a96930c69ee92973ac31bdd41851dea071af14cd4bbaf8480
DIST ujson-1.35.tar.gz 192027 BLAKE2B 320058e7142f2264bee8b02a411bedb3b32d1c2fc86157eb47272f75cb401e6c75ce7d9e3dba5092cd1db99dbded8804347d4c7be11eaedb47bc8b4b8125fbd3 SHA512 931d8f574fc4920c9ded48369774666060e951f40982606ce9f1d9de3420004042af7d797075a54d92a2b25c4f313572a5e1a30f3bc8ce387ef8f3881193eee7
diff --git a/dev-python/ujson/files/ujson-1.33-test-py3.patch b/dev-python/ujson/files/ujson-1.33-test-py3.patch
deleted file mode 100644
index e497f396792c..000000000000
--- a/dev-python/ujson/files/ujson-1.33-test-py3.patch
+++ /dev/null
@@ -1,38 +0,0 @@
- tests/tests.py | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/tests/tests.py b/tests/tests.py
-index d210bc6..71f8074 100644
---- a/tests/tests.py
-+++ b/tests/tests.py
-@@ -11,6 +11,7 @@ try:
- except ImportError:
- import simplejson as json
- import math
-+import nose
- import platform
- import sys
- import time
-@@ -24,9 +25,10 @@ from functools import partial
-
- PY3 = (sys.version_info[0] >= 3)
-
--def _python_ver(skip_major, skip_minor=None):
-+def _skip_if_python_ver(skip_major, skip_minor=None):
- major, minor = sys.version_info[:2]
-- return major == skip_major and (skip_minor is None or minor == skip_minor)
-+ if major == skip_major and (skip_minor is None or minor == skip_minor):
-+ raise nose.SkipTest
-
- json_unicode = (json.dumps if sys.version_info[0] >= 3
- else partial(json.dumps, encoding="utf-8"))
-@@ -579,8 +581,8 @@ class UltraJSONTests(TestCase):
- input = "-31337"
- self.assertEquals (-31337, ujson.decode(input))
-
-- #@unittest.skipIf(_python_ver(3), "No exception in Python 3")
- def test_encodeUnicode4BytesUTF8Fail(self):
-+ _skip_if_python_ver(3)
- input = "\xfd\xbf\xbf\xbf\xbf\xbf"
- try:
- enc = ujson.encode(input)
diff --git a/dev-python/ujson/ujson-1.33.ebuild b/dev-python/ujson/ujson-1.33.ebuild
deleted file mode 100644
index 21bf458e20fc..000000000000
--- a/dev-python/ujson/ujson-1.33.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# One test; FAIL: test_encodeToUTF8 (__main__.UltraJSONTests) under py2.5.
-# Fix and repair and re-insert if it's REALLY needed
-PYTHON_COMPAT=( python2_7 python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
-HOMEPAGE="https://pypi.org/project/ujson/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- app-arch/unzip"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-test-py3.patch
-)
-
-python_test() {
- # See setup.py; line 72. Again "${S}" is used for reading tests
- # Since py3_2 is first in the queue it needs its own copy
- # or else all py2s to follow will be reading read py3 tests
- if [[ "${EPYTHON}" =~ 'python3' ]]; then
- cd "${BUILD_DIR}"/lib || die
- cp -a "${S}"/tests/ . || die
- 2to3 -w tests/tests.py || die
- "${PYTHON}" tests/tests.py || die
- rm -rf tests/ || die
- else
- "${PYTHON}" tests/tests.py || die
- fi
-}